AUTOTRUCK CLUB

THE CLUB FOR SMALL INDUSTRIAL / HORTICULTURAL TRUCKS LISTER, MERCURY, WRIGLEY, WRIGLEY UNION, BONSER, MARTIN, GEEST ETC.

FORUM

Post Reply
Forum Home > General Discussion > bonsor questions

rathopete
Member
Posts: 2

I recently acquired a one ton bonsor.  Having got it running I have a couple of questions that I hope some guys here might be able to help with!

I am having difficulties with the gear change, the clutch seems to be disengaging but while reverse is fine and first possible, second and third are hard. is this the clutch or the gearbox?

 

Also the koler seems to run fine but runs what I would consider to be very hot. I have fitted an exhaust as it was missing and it discharges to the nearside just behind and beneath the fuel tank, I think this might be contributing to the heat of the engine, so I am going to re-route the exhaust further back beneath the load box to try to reduce this. Does this sound sensible?


Thanks pete

April 19, 2014 at 4:31 PM Flag Quote & Reply

Colin Hope
Member
Posts: 6

Hello, Pete! My Bonser Model E was hard to get into gear, and the gears didn't match up with the notches in the quadrant. I  refurbed the gearchange linkage (slightly larger pins in all the joints) and this helped - BUT it might not be the same problem that your Bonser has. Good luck with the gears! All the best, Colin Hope

April 22, 2014 at 3:37 PM Flag Quote & Reply

rathopete
Member
Posts: 2

thanks Colin for the reply! I am going to renew the pin to as there is at least 1/2" of play overall.  Did/does yours have a kohler engine and if so does it run hot|?

I have now moved the exhaust as I mentioned above and that has helped but still running rather warm in my opinion.


pete

April 22, 2014 at 5:36 PM Flag Quote & Reply

You must login to post.